CVE-2023-32985 is a medium-severity (CVSS 4.3) Path Traversal vulnerability in org.jenkins-ci.plugins:sidebar-link. EPSS puts its 30-day exploitation probability at 72.4% (99th percentile). A fix is available for org.jenkins-ci.plugins:sidebar-link — see the affected versions and patch details below.
Jenkins Sidebar Link Plugin vulnerable to Path Traversal
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32985.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:sidebar-linkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Sidebar Link Plugin allows specifying files in the userContent/ directory for use as link icons.
Sidebar Link Plugin 2.2.1 and earlier does not restrict the path of files in a method implementing form validation.
This allows attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.
Sidebar Link Plugin 2.2.2 ensures that only files located within the expected userContent/ directory can be accessed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:sidebar-link | all versions | 2.2.2org.jenkins-ci.plugins:sidebar-link:2.2.2 |
Affected Products
sidebar linkjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:sidebar-link, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:sidebar-link to 2.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32985 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2023-32985 in your dependencies?
Find it across Maven, including transitive dependencies.