CVE-2023-32062 is a medium-severity (CVSS 5) CWE-284 vulnerability in oro/calendar-bundle. A fix is available for oro/calendar-bundle — see the affected versions and patch details below.
OroCalendarBundle has incorrect system calendar events visibility
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
oro/calendar-bundle🐘oro/calendar-bundle🐘oro/calendar-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
OroPlatform is a package that assists system and user calendar management. Back-office users can access information from any system calendar event, bypassing ACL security restrictions due to insufficient security checks. This vulnerability has been patched in version 5.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | oro/calendar-bundle | ≥ 4.2.0 | No fix |
| 🐘Packagist | oro/calendar-bundle | ≥ 5.0.0&&< 5.0.7 | 5.0.7composer require oro/calendar-bundle:^5.0.7 |
| 🐘Packagist | oro/calendar-bundle | ≥ 5.1.0&&< 5.1.1 | 5.1.1composer require oro/calendar-bundle:^5.1.1 |
Affected Products
oroplatformoroincDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oro/calendar-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2023-32062; check the affected-versions list above or the advisory for the patched release of oro/calendar-bundle, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-32062 in your dependencies?
Find it across Packagist, including transitive dependencies.