CVE-2023-31101 is a medium-severity (CVSS 6.5) CWE-1188 vulnerability in org.apache.inlong:manager-dao. A fix is available for org.apache.inlong:manager-dao — see the affected versions and patch details below.
User data exposure in Apache InLong
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31101.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.inlong:manager-dao☕org.apache.inlong:manager-pojo☕org.apache.inlong:manager-service☕org.apache.inlong:manager-webReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Insecure Default Initialization of Resource Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.6.0. Users registered in InLong who joined later can see deleted users' data. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.inlong:manager-dao | ≥ 1.5.0&&< 1.7.0 | 1.7.0org.apache.inlong:manager-dao:1.7.0 |
| ☕Maven | org.apache.inlong:manager-pojo | ≥ 1.5.0&&< 1.7.0 | 1.7.0org.apache.inlong:manager-pojo:1.7.0 |
| ☕Maven | org.apache.inlong:manager-service | ≥ 1.5.0&&< 1.7.0 | 1.7.0org.apache.inlong:manager-service:1.7.0 |
| ☕Maven | org.apache.inlong:manager-web | ≥ 1.5.0&&< 1.7.0 | 1.7.0org.apache.inlong:manager-web:1.7.0 |
Affected Products
inlongapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.inlong:manager-dao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.inlong:manager-dao to 1.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31101 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-31101 in your dependencies?
Find it across Maven, including transitive dependencies.