NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-31065 — manager-pojo

CRITICALFix: apache/inlong#7836

CVE-2023-31065 is a critical-severity (CVSS 9.1) CWE-613 vulnerability in org.apache.inlong:manager-pojo. A fix is available for org.apache.inlong:manager-pojo — see the affected versions and patch details below.

Apache InLong Insufficient Session Expiration vulnerability

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31065.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.11%1.66%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.inlong:manager-pojo☕org.apache.inlong:manager-dao☕org.apache.inlong:manager-web☕org.apache.inlong:manager-service

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. 

An old session can be used by an attacker even after the user has been deleted or the password has been changed.

Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.inlong:manager-pojo≥ 1.4.0&&< 1.7.01.7.0org.apache.inlong:manager-pojo:1.7.0
☕Mavenorg.apache.inlong:manager-dao≥ 1.4.0&&< 1.7.01.7.0org.apache.inlong:manager-dao:1.7.0
☕Mavenorg.apache.inlong:manager-web≥ 1.4.0&&< 1.7.01.7.0org.apache.inlong:manager-web:1.7.0
☕Mavenorg.apache.inlong:manager-service≥ 1.4.0&&< 1.7.01.7.0org.apache.inlong:manager-service:1.7.0

Affected Products

1 product · 1 configurations
Application
inlongapache
≥ 1.4.0 && ≤ 1.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.inlong:manager-pojo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.inlong:manager-pojo to 1.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31065 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0.  An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 or https://github.com/apache/inlong/pull/7884 to solve it.
O3 Security · Impact-Aware SCA

Is CVE-2023-31065 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-31065: manager-pojo — Fixed in 1.7.0