NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

CVE-2023-31048 — OPCFoundation.NetStandard…

MEDIUM

CVE-2023-31048 is a medium-severity (CVSS 5.3) CWE-209 vulnerability in OPCFoundation.NetStandard.Opc.Ua.Core. A fix is available for OPCFoundation.NetStandard.Opc.Ua.Core — see the affected versions and patch details below.

Exposure of Sensitive Information in OPC UA .NET Standard Reference Server

Also known asGHSA-4cvp-hr63-822j
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31048.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.43%0.86%1.29%0.4%0.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETOPCFoundation.NetStandard.Opc.Ua.Core.NETOPCFoundation.NetStandard.Opc.Ua.Server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

This security update resolves a vulnerability in the OPC UA .NET Standard Reference Server that allows remote attackers to send malicious requests that expose sensitive information.

https://files.opcfoundation.org/SecurityBulletins/OPC%20Foundation%20Security%20Bulletin%20CVE-2023-31048.pdf

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetOPCFoundation.NetStandard.Opc.Ua.Coreall versions1.4.371.86dotnet add package OPCFoundation.NetStandard.Opc.Ua.Core --version 1.4.371.86
.NETNuGetOPCFoundation.NetStandard.Opc.Ua.Serverall versions1.4.371.86dotnet add package OPCFoundation.NetStandard.Opc.Ua.Server --version 1.4.371.86

Affected Products

1 product · 1 configurations
Application
ua-.netstandardopcfoundation
< 1.4.371.86
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for OPCFoundation.NetStandard.Opc.Ua.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update OPCFoundation.NetStandard.Opc.Ua.Core to 1.4.371.86 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31048 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

This security update resolves a vulnerability in the OPC UA .NET Standard Reference Server that allows remote attackers to send malicious requests that expose sensitive information. https://files.opcfoundation.org/SecurityBulletins/OPC%20Foundation%20Security%20Bulletin%20CVE-2023-31048.pdf
O3 Security · Impact-Aware SCA

Is CVE-2023-31048 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2023-31048: OPCFoundation — Fixed in 1.4.371.86