NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2022-29863 — OPCFoundation.NetStandard…

HIGH

CVE-2022-29863 is a high-severity (CVSS 7.5) CWE-770 vulnerability in OPCFoundation.NetStandard.Opc.Ua.Core. A fix is available for OPCFoundation.NetStandard.Opc.Ua.Core — see the affected versions and patch details below.

Memory Allocation with Excessive Size Value in OPCFoundation.NetStandard.Opc.Ua.Core

Also known asGHSA-r7pq-3x6p-7jcm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.13%0.75%1.37%1.98%0.6%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETOPCFoundation.NetStandard.Opc.Ua.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was discovered in the OPC UA .NET Standard Stack that allows a malicious client to cause a server to trigger an out of memory exception with a carefully crafted message.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetOPCFoundation.NetStandard.Opc.Ua.Coreall versions1.4.368.58dotnet add package OPCFoundation.NetStandard.Opc.Ua.Core --version 1.4.368.58

Affected Products

1 product · 1 configurations
Application
ua .net standard stackopcfoundation
< 1.4.368.58
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for OPCFoundation.NetStandard.Opc.Ua.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update OPCFoundation.NetStandard.Opc.Ua.Core to 1.4.368.58 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29863 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

A vulnerability was discovered in the OPC UA .NET Standard Stack that allows a malicious client to cause a server to trigger an out of memory exception with a carefully crafted message.
O3 Security · Impact-Aware SCA

Is CVE-2022-29863 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2022-29863: OPCFoundation — Fixed in 1.4.368.58