NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-3072 — nomad

MEDIUM

CVE-2023-3072 is a medium-severity (CVSS 4.1) CWE-266 vulnerability in github.com/hashicorp/nomad. A fix is available for github.com/hashicorp/nomad — see the affected versions and patch details below.

Nomad ACL Policies without Label are Applied to Unexpected Resources

Also known asGHSA-rpvr-38xv-xvxqGO-2024-2670
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-3072.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.31%0.62%0.94%0.1%0.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/hashicorp/nomad🐹github.com/hashicorp/nomad

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was identified in Nomad, an ACL policy using a block without label may be applied to unexpected resources. This vulnerability, CVE-2023-3072, affects Nomad from 0.7 up to 1.5.6 and 1.4.10 and was fixed in 1.6.0, 1.5.7, and 1.4.11.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/hashicorp/nomad≥ 0.7.0&&< 1.4.111.4.11go get github.com/hashicorp/nomad@v1.4.11
🐹Gogithub.com/hashicorp/nomad≥ 1.5.0&&< 1.5.61.5.6go get github.com/hashicorp/nomad@v1.5.6

Affected Products

1 product · 4 configurations
Application
nomadhashicorp
≥ 1.5.0 && ≤ 1.5.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/nomad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/hashicorp/nomad to 1.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-3072 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A vulnerability was identified in Nomad, an ACL policy using a block without label may be applied to unexpected resources. This vulnerability, CVE-2023-3072, affects Nomad from 0.7 up to 1.5.6 and 1.4.10 and was fixed in 1.6.0, 1.5.7, and 1.4.11.
O3 Security · Impact-Aware SCA

Is CVE-2023-3072 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-3072: nomad — Fixed in 1.4.11