NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-2974 — quarkus-core

MEDIUMFix: quarkusio/quarkus#34469

CVE-2023-2974 is a medium-severity (CVSS 6.5) CWE-757 vulnerability in io.quarkus:quarkus-core. A fix is available for io.quarkus:quarkus-core — see the affected versions and patch details below.

quarkus-core vulnerable to client driven TLS cipher downgrading

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.5%0.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.quarkus:quarkus-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was found in quarkus-core. This vulnerability occurs because the TLS protocol configured with quarkus.http.ssl.protocols is not enforced, and the client can force the selection of the weaker supported TLS protocol.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.quarkus:quarkus-coreall versions2.16.8.Finalio.quarkus:quarkus-core:2.16.8.Final

Affected Products

1 product · 1 configurations
Application
build of quarkusredhat
< 2.13.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.quarkus:quarkus-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.quarkus:quarkus-core to 2.16.8.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2974 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat build of Quarkus 2.13.8.Finalio.quarkus/quarkus-grpc:2.13.8.Final-redhat-00004RHSA-2023:3809

Frequently Asked Questions

A vulnerability was found in quarkus-core. This vulnerability occurs because the TLS protocol configured with quarkus.http.ssl.protocols is not enforced, and the client can force the selection of the weaker supported TLS protocol.
O3 Security · Impact-Aware SCA

Is CVE-2023-2974 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-2974: quarkus-core — Fixed in 2.16.8.Final