NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-2972 — @antfu/utils

MEDIUMFix: antfu/utils@7f8b16c

CVE-2023-2972 is a medium-severity (CVSS 5.4) CWE-1321 vulnerability in @antfu/utils. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @antfu/utils — see the affected versions and patch details below.

Prototype Pollution in antfu/utils

Also known asGHSA-p2fh-2h23-6grg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-2972.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%0.99%1.49%0.1%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

274other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@antfu/utilsnpm
3.5Mdownloads / week

Description

Prototype Pollution in GitHub repository antfu/utils prior to 0.7.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@antfu/utilsall versions0.7.3npm install @antfu/utils@0.7.3

Affected Products

1 product · 1 configurations
Application
utilsantfu
< 0.7.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @antfu/utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @antfu/utils to 0.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-2972 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Prototype Pollution in GitHub repository antfu/utils prior to 0.7.3.
O3 Security · Impact-Aware SCA

Is CVE-2023-2972 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-2972: @antfu/utils — Fixed in 0.7.3