CVE-2023-29009 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.
basercms XSS Vulnerability via Favorites Feature
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29009.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
baserproject/basercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
There is a XSS Vulnerability in Favorites Feature to baserCMS.
This is a vulnerability that needs to be addressed when the management system is used by an unspecified number of users. If you are eligible, please update to the new version as soon as possible.
Target
baserCMS 4.7.8 and earlier versions
Vulnerability
Malicious code could be executed in the Favorites feature on the server.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information. https://basercms.net/security/JVN_45547161
Credits
ota kyohei
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | baserproject/basercms | all versions | 4.8.0composer require baserproject/basercms:^4.8.0 |
Affected Products
basercmsbasercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update baserproject/basercms to 4.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-29009 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-29009 in your dependencies?
Find it across Packagist, including transitive dependencies.