CVE-2023-26154 is a medium-severity (CVSS 5.9) CWE-331 vulnerability in pubnub. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pubnub — see the affected versions and patch details below.
pubnub Insufficient Entropy vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pubnub🐹github.com/pubnub/go/v7🐹github.com/pubnub/go🐹github.com/pubnub/go/v6🐹github.com/pubnub/go/v5☕com.pubnub:pubnub-kotlin☕com.pubnub:pubnub📦pubnub+6 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io, Go packages — download data is not available via public APIs for these ecosystems.
Description
Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; all versions of the package github.com/pubnub/go; versions of the package github.com/pubnub/go/v7 before 7.2.0; versions of the package pubnub before 7.3.0; versions of the package pubnub/pubnub before 6.1.0; versions of the package pubnub before 5.3.0; versions of the package pubnub before 0.4.0; versions of the package pubnub/c-core before 4.5.0; versions of the package com.pubnub:pubnub-kotlin before 7.7.0; versions of the package pubnub/swift before 6.2.0; versions of the package pubnub before 5.2.0; versions of the package pubnub before 4.3.0 are vulnerable to Insufficient Entropy via the getKey function, due to inefficient implementation of the AES-256-CBC cryptographic algorithm. The provided encrypt function is less secure when hex encoding and trimming are applied, leaving half of the bits in the key always the same for every encoded message or file.
Note:
In order to exploit this vulnerability, the attacker needs to invest resources in preparing the attack and brute-force the encryption.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | pubnub | all versions | 0.4.0cargo update -p pubnub --precise 0.4.0 |
| 🐹Go | github.com/pubnub/go/v7 | all versions | 7.2.0go get github.com/pubnub/go/v7@v7.2.0 |
| 🐹Go | github.com/pubnub/go | all versions | 0.0.0-20231016150651-428517fef5b9go get github.com/pubnub/go@v0.0.0-20231016150651-428517fef5b9 |
| 🐹Go | github.com/pubnub/go/v6 | all versions | 6.1.1-0.20231016150651-428517fef5b9go get github.com/pubnub/go/v6@v6.1.1-0.20231016150651-428517fef5b9 |
| 🐹Go | github.com/pubnub/go/v5 | all versions | 5.0.4-0.20231016150651-428517fef5b9go get github.com/pubnub/go/v5@v5.0.4-0.20231016150651-428517fef5b9 |
| ☕Maven | com.pubnub:pubnub-kotlin | all versions | 7.7.0com.pubnub:pubnub-kotlin:7.7.0 |
Affected Products
c-corepubnubkotlinpubnubpubnubpubnubswiftpubnubResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pubnub, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pubnub to 0.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26154 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-26154 in your dependencies?
Find it across crates.io, Go, Maven, including transitive dependencies.