CVE-2023-26125 is a medium-severity (CVSS 5.6) Improper Input Validation vulnerability in github.com/gin-gonic/gin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/gin-gonic/gin — see the affected versions and patch details below.
Improper input validation in github.com/gin-gonic/gin
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26125.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/gin-gonic/ginReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Versions of the package github.com/gin-gonic/gin before version 1.9.0 are vulnerable to Improper Input Validation by allowing an attacker to use a specially crafted request via the X-Forwarded-Prefix header, potentially leading to cache poisoning.
Note: Although this issue does not pose a significant threat on its own it can serve as an input vector for other more impactful vulnerabilities. However, successful exploitation may depend on the server configuration and whether the header is used in the application logic.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/gin-gonic/gin | all versions | 1.9.0go get github.com/gin-gonic/gin@v1.9.0 |
Affected Products
gingin-gonicResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gin-gonic/gin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/gin-gonic/gin to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26125 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2023-26125 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Migration Toolkit for Virtualization 2.5 | migration-toolkit-virtualization/mtv-controller-rhel9:2.5.2-5 | RHBA-2023:6078 |
| MTA-6.2-RHEL-9 | mta/mta-hub-rhel9:6.2.0-16 | RHSA-2023:4627 |
| Red Hat Migration Toolkit for Containers 1.7 | rhmtc/openshift-migration-controller-rhel8:v1.7.11-4 | RHSA-2023:4293 |
| Red Hat OpenShift Container Platform 4.13 | openshift4/ose-agent-installer-csr-approver-rhel8:v4.13.0-202411300029.p0.g19034d8.assembly.stream.el8 | RHSA-2024:10813 |
| Red Hat OpenShift Container Platform 4.13 | openshift4/ose-agent-installer-api-server-rhel8:v4.13.0-202410242307.p0.gec6e27b.assembly.stream.el8 | RHSA-2024:8688 |
Frequently Asked Questions
Is CVE-2023-26125 in your dependencies?
Find it across Go, including transitive dependencies.