NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2023-26052 — saleor

LOW

CVE-2023-26052 is a low-severity (CVSS 3.7) CWE-209 vulnerability in saleor. A fix is available for saleor — see the affected versions and patch details below.

Saleor is vulnerable to unauthenticated information disclosure via Python exceptions

Also known asGHSA-3hvj-3cg9-v242PYSEC-2026-915
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-26052.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.84%1.26%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐍saleor🐍saleor🐍saleor🐍saleor🐍saleor🐍saleor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Some internal Python exceptions are not handled properly and thus are returned in API as error messages. Some messages might contain sensitive information like infrastructure details in unauthenticated requests.

Affected versions: Saleor ≥ 2.0.0

Workarounds

None

For more information

If you have any questions or comments about this advisory:

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsaleor≥ 2.0.0&&< 3.1.483.1.48pip install --upgrade 'saleor==3.1.48'
🐍PyPIsaleor≥ 3.11.0&&< 3.11.123.11.12pip install --upgrade 'saleor==3.11.12'
🐍PyPIsaleor≥ 3.10.0&&< 3.10.143.10.14pip install --upgrade 'saleor==3.10.14'
🐍PyPIsaleor≥ 3.9.0&&< 3.9.273.9.27pip install --upgrade 'saleor==3.9.27'
🐍PyPIsaleor≥ 3.8.0&&< 3.8.303.8.30pip install --upgrade 'saleor==3.8.30'
🐍PyPIsaleor≥ 3.7.0&&< 3.7.593.7.59pip install --upgrade 'saleor==3.7.59'

Affected Products

1 product · 6 configurations
Application
saleorsaleor
≥ 3.11.0 && < 3.11.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for saleor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update saleor to 3.1.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-26052 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Some internal Python exceptions are not handled properly and thus are returned in API as error messages. Some messages might contain sensitive information like infrastructure details in unauthenticated requests. Affected versions: Saleor ≥ 2.0.0 ### Workarounds None ### For more information If you have any questions or comments about this advisory: * Open a discussion at https://github.com/saleor/saleor/discussions * Email us at [[email protected]](mailto:[email protected])
O3 Security · Impact-Aware SCA

Is CVE-2023-26052 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-26052: saleor — Fixed in 3.1.48