CVE-2020-7964 is a medium-severity (CVSS 5.3) Missing Authentication vulnerability in saleor. A fix is available for saleor — see the affected versions and patch details below.
Missing Authentication for Critical Function in Saleor
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
saleorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Mirumee Saleor 2.x before 2.9.1. Incorrect access control in the checkoutCustomerAttach mutations allows attackers to attach their checkouts to any user ID and consequently leak user data (e.g., name, address, and previous orders of any other customer).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | saleor | ≥ 2.0.0&&< 2.9.1 | 2.9.1pip install --upgrade 'saleor==2.9.1' |
Affected Products
saleormirumeeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for saleor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update saleor to 2.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7964 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2020-7964 in your dependencies?
Find it across PyPI, including transitive dependencies.