NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-25158 — gt-jdbc

CRITICALFix: geotools/geotools@64fb4c4

CVE-2023-25158 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in org.geotools:gt-jdbc. A fix is available for org.geotools:gt-jdbc — see the affected versions and patch details below.

Unfiltered SQL Injection in Geotools

Also known asGHSA-99c3-qc2q-p94m
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%1.91%3.82%5.73%4.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.geotools:gt-jdbc☕org.geotools:gt-jdbc☕org.geotools:gt-jdbc☕org.geotools:gt-jdbc☕org.geotools:gt-jdbc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

GeoTools includes support for OGC Filter expression language parsing, encoding and execution against a range of datastore.

SQL Injection Vulnerabilities have been found when executing OGC Filters with JDBCDataStore implementations:

  1. PropertyIsLike filter
    • Requires PostGIS DataStore with "encode functions" enabled
    • Or any JDBCDataStore (all relational databases) with String field (no mitigation)
  2. strEndsWith function
    • Requires PostGIS DataStore with "encode functions" enabled
  3. strStartsWith function
    • Requires PostGIS DataStore with "encode functions" enabled
  4. FeatureId filter
    • Requires JDBCDataStore (all relational databases) with prepared statements disabled and table with String primary key (Oracle not affected, SQL Server and MySQL have no settings to enabled prepared statements, PostGIS does)
  5. jsonArrayContains function
    • Requires PostGIS and Oracle DataStore with String or JSON field
  6. DWithin filter
    • Happens only in Oracle DataStore, no mitigation

Patches

  • GeoTools 28.2
  • GeoTools 27.4
  • GeoTools 26.7
  • GeoTools 25.7
  • GeoTools 24.7

Workarounds

Partial mitigation:

  • In PostGIS DataStore disable "encode functions"
  • In any PostGIS enable "prepared statements" (only database with such settings)
        Map<String, Object> params = new HashMap<>();
        params.put("dbtype", "postgis");
        params.put("host", "localhost");
        params.put("port", 5432);
        params.put("schema", "public");
        params.put("database", "database");
        params.put("user", "postgres");
        params.put("passwd", "postgres");
        params.put("preparedStatements", true ); // mitigation
        params.put("encode functions", false ); // mitigation

        DataStore dataStore = DataStoreFinder.getDataStore(params);

References

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.geotools:gt-jdbc≥ 28.0&&< 28.228.2org.geotools:gt-jdbc:28.2
☕Mavenorg.geotools:gt-jdbc≥ 27.0&&< 27.427.4org.geotools:gt-jdbc:27.4
☕Mavenorg.geotools:gt-jdbc≥ 26.0&&< 26.726.7org.geotools:gt-jdbc:26.7
☕Mavenorg.geotools:gt-jdbc≥ 25.0&&< 25.725.7org.geotools:gt-jdbc:25.7
☕Mavenorg.geotools:gt-jdbcall versions24.7org.geotools:gt-jdbc:24.7

Affected Products

1 product · 5 configurations
Application
geotoolsgeotools
≥ 28.0 && < 28.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geotools:gt-jdbc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.geotools:gt-jdbc to 28.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25158 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Impact GeoTools includes support for OGC Filter expression language parsing, encoding and execution against a range of datastore. SQL Injection Vulnerabilities have been found when executing OGC Filters with JDBCDataStore implementations: 1. ``PropertyIsLike`` filter * Requires PostGIS DataStore with "encode functions" enabled * Or any JDBCDataStore (all relational databases) with String field (no mitigation) 3. ``strEndsWith`` function * Requires PostGIS DataStore with "encode functions" enabled 5. ``strStartsWith`` function * Requires PostGIS DataStore with "encode functio
O3 Security · Impact-Aware SCA

Is CVE-2023-25158 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-25158: gt-jdbc SQL Injection — Fixed in 28.2