Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-25157 — gs-jdbcconfig

CRITICALFix: geoserver/geoserver@145a8af

CVE-2023-25157 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in org.geoserver.community:gs-jdbcconfig. 10 public exploit references exist, so weaponization risk is real. A fix is available for org.geoserver.community:gs-jdbcconfig — see the affected versions and patch details below.

Unfiltered SQL Injection Vulnerabilities in Geoserver

Also known asGHSA-7g5f-wrx8-5ccf
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
10 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
85.2%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
82.6%87.3%92.0%96.7%94.0%85.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2023-25157 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 395,308 CVEs with a current EPSS score, this one falls in the 50–90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

2 pkgs affected
☕org.geoserver.community:gs-jdbcconfig☕org.geoserver.community:gs-jdbcconfig

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages.

SQL Injection Vulnerabilities have been found with:

  • PropertyIsLike filter, when used with a String field and any database DataStore, or with a PostGIS DataStore with encode functions enabled
  • strEndsWith function, when used with a PostGIS DataStore with encode functions enabled
  • strStartsWith function, when used with a PostGIS DataStore with encode functions enabled
  • FeatureId filter, when used with any database table having a String primary key column and when prepared statements are disabled
  • jsonArrayContains function, when used with a String or JSON field and with a PostGIS or Oracle DataStore (GeoServer 2.22.0+ only)
  • DWithin filter, when used with an Oracle DataStore

Patches

  • GeoSever 2.21.4
  • GeoServer 2.22.2
  • GeoServer 2.20.7
  • GeoServer 2.19.7
  • GeoServer 2.18.7

Workarounds

  1. Disabling the PostGIS Datastore encode functions setting to mitigate strEndsWith, strStartsWith vulnerabilities (Like filters have no mitigation, if there is a string field in the feature type published).
  2. Enabling the PostGIS DataStore preparedStatements setting to mitigate the FeatureId vulnerability.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.geoserver.community:gs-jdbcconfigall versions2.21.4org.geoserver.community:gs-jdbcconfig:2.21.4
☕Mavenorg.geoserver.community:gs-jdbcconfig≥ 2.22.0&&< 2.22.22.22.2org.geoserver.community:gs-jdbcconfig:2.22.2

Affected Products

1 product · 5 configurations
Application
geoserverosgeo
≥ 2.22.0 && < 2.22.2
range
Exploits & PoCs
10

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geoserver.community:gs-jdbcconfig, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.geoserver.community:gs-jdbcconfig to 2.21.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25157 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

How to detect CVE-2023-25157

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-25157 -u https://target
Template
GeoServer OGC Filter - SQL Injection
Severity
critical
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary SQL queries, potentially leading to unauthorized access, data leakage, or data manipulation.
Remediation
Apply the latest security patches or updates provided by the GeoServer project to fix the SQL Injection vulnerability.

Template by ProjectDiscovery nuclei-templates (ritikchaddha, DhiyaneshDK, iamnoooob), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. SQL Injection Vulnerabilities have been found with: * ``PropertyIsLike`` filter, when used with a String field and any database DataStore, or with a PostGIS DataStore with encode functions enabled * ``strEndsWith`` function, when used with a PostGIS DataStore with encode functions enabled * ``strStartsW
O3 Security · Impact-Aware SCA

Is CVE-2023-25157 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-25157: gs-jdbcconfig — Fixed in 2.21.4