NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-1541 — answer

MEDIUMFix: answerdev/answer@15390ad

CVE-2023-1541 is a medium-severity (CVSS 6) CWE-840 vulnerability in github.com/answerdev/answer. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/answerdev/answer — see the affected versions and patch details below.

Business Logic Errors in answerdev/answer

Also known asGHSA-h2wg-83fc-xvm9GO-2023-1658
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1541.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.4%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/answerdev/answer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Business Logic Errors in GitHub repository answerdev/answer prior to 1.0.6.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/answerdev/answerall versions1.0.6go get github.com/answerdev/answer@v1.0.6

Affected Products

1 product · 1 configurations
Application
answeranswer
< 1.0.6
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/answerdev/answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/answerdev/answer to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1541 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Business Logic Errors in GitHub repository answerdev/answer prior to 1.0.6.
O3 Security · Impact-Aware SCA

Is CVE-2023-1541 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-1541: answer — Fixed in 1.0.6