NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-4124 — answer

HIGHFix: answerdev/answer@964195f

CVE-2023-4124 is a high-severity (CVSS 8.1) CWE-862 vulnerability in github.com/answerdev/answer. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/answerdev/answer — see the affected versions and patch details below.

Missing Authorization in answerdev/answer

Also known asGHSA-v9vc-7x69-c2x8GO-2023-1997
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-4124.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.77%1.15%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/answerdev/answer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Missing Authorization in GitHub repository answerdev/answer prior to v1.1.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/answerdev/answerall versions1.1.1go get github.com/answerdev/answer@v1.1.1

Affected Products

1 product · 1 configurations
Application
answeranswer
< 1.1.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/answerdev/answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/answerdev/answer to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-4124 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Missing Authorization in GitHub repository answerdev/answer prior to v1.1.1.
O3 Security · Impact-Aware SCA

Is CVE-2023-4124 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-4124: answer — Fixed in 1.1.1