NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2023-0777 — modoboa

HIGHFix: modoboa/modoboa@47d17ac

CVE-2023-0777 is a high-severity (CVSS 8.6) CWE-305 vulnerability in modoboa. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for modoboa — see the affected versions and patch details below.

Authentication Bypass by Primary Weakness in modoboa/modoboa

Also known asGHSA-rfhw-fm4m-52j6PYSEC-2023-32
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0777.

EPSS Exploitation Probability

via FIRST.org ↗
15.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%31.5%63.0%94.5%76.2%15.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍modoboa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Authentication Bypass by Primary Weakness in GitHub repository modoboa/modoboa prior to 2.0.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImodoboaall versions2.0.4pip install --upgrade 'modoboa==2.0.4'

Affected Products

1 product · 1 configurations
Application
modoboamodoboa
< 2.0.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-51276webappspython

modoboa 2.0.4 - Admin TakeOver

by 7h3h4ckv157 · Apr 6, 2023

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modoboa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modoboa to 2.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0777 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

How to detect CVE-2023-0777

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-0777 -u https://target
Template
modoboa 2.0.4 - Admin TakeOver
Severity
critical
Impact
Unauthenticated attackers can exploit authentication bypass using default credentials to gain administrator access and completely compromise Modoboa email server installations.
Remediation
update to version 2.0.4

Template by ProjectDiscovery nuclei-templates (r3Y3r53), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Authentication Bypass by Primary Weakness in GitHub repository modoboa/modoboa prior to 2.0.4.
O3 Security · Impact-Aware SCA

Is CVE-2023-0777 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-0777: modoboa Auth Bypass — Fixed in 2.0.4