NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-0759 — cockpit

MEDIUMFix: cockpit-hq/cockpit@78d6ed3

CVE-2023-0759 is a medium-severity (CVSS 5.3) CWE-268 vulnerability in cockpit-hq/cockpit. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cockpit-hq/cockpit — see the affected versions and patch details below.

Privilege Chaining in cockpit-hq/cockpit

Also known asGHSA-86rf-38v8-9c4x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0759.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs28th percentile — riskier than 28% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘cockpit-hq/cockpit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Privilege Chaining in GitHub repository cockpit-hq/cockpit prior to 2.3.8.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcockpit-hq/cockpitall versions2.3.8composer require cockpit-hq/cockpit:^2.3.8

Affected Products

1 product · 1 configurations
Application
cockpitagentejo
< 2.3.8
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cockpit-hq/cockpit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cockpit-hq/cockpit to 2.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0759 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Privilege Chaining in GitHub repository cockpit-hq/cockpit prior to 2.3.8.
O3 Security · Impact-Aware SCA

Is CVE-2023-0759 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-0759: cockpit — Fixed in 2.3.8