NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2023-0744 — answer

CRITICALFix: answerdev/answer@c1fa2b1

CVE-2023-0744 is a critical-severity (CVSS 9.8) CWE-284 vulnerability in github.com/answerdev/answer. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/answerdev/answer — see the affected versions and patch details below.

Improper Access Control in answerdev/answer

Also known asGHSA-4cwh-8w4g-jxxhGO-2023-1550
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-0744.

EPSS Exploitation Probability

via FIRST.org ↗
6.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
5.72%6.87%8.02%9.16%8.5%8.5%6.4%6.4%6.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/answerdev/answer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Improper Access Control in GitHub repository answerdev/answer prior to 1.0.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/answerdev/answerall versions1.0.4go get github.com/answerdev/answer@v1.0.4

Affected Products

1 product · 1 configurations
Application
answeranswer
< 1.0.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-51257webappsgo✓ Verified

Answerdev 1.0.3 - Account Takeover

by Eduardo Pérez-Malumbres Cervera · Apr 5, 2023

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/answerdev/answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/answerdev/answer to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-0744 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Improper Access Control in GitHub repository answerdev/answer prior to 1.0.4.
O3 Security · Impact-Aware SCA

Is CVE-2023-0744 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-0744: answer — Fixed in 1.0.4