NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-4886 — ingress-nginx

HIGH

CVE-2022-4886 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in k8s.io/ingress-nginx. A fix is available for k8s.io/ingress-nginx — see the affected versions and patch details below.

Ingress-nginx `path` sanitization can be bypassed with `log_format` directive

Also known asGHSA-gvrm-w2f9-f77q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4886.

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk+0.21%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.51%2.26%0.2%1.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹k8s.io/ingress-nginx

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Ingress-nginx path sanitization can be bypassed with log_format directive.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gok8s.io/ingress-nginxall versions1.8.0go get k8s.io/ingress-nginx@v1.8.0

Affected Products

1 product · 1 configurations
Application
ingress-nginxkubernetes
< 1.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/ingress-nginx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update k8s.io/ingress-nginx to 1.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4886 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Ingress-nginx `path` sanitization can be bypassed with `log_format` directive.
O3 Security · Impact-Aware SCA

Is CVE-2022-4886 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-4886: ingress-nginx — Fixed in 1.8.0