CVE-2025-24513 — ingress-nginx
MEDIUMCVE-2025-24513 is a medium-severity (CVSS 4.8) Improper Input Validation vulnerability in k8s.io/ingress-nginx. A fix is available for k8s.io/ingress-nginx — see the affected versions and patch details below.
ingress-nginx controller - auth secret file path traversal vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-24513.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
k8s.io/ingress-nginx🐹k8s.io/ingress-nginxReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A security issue was discovered in ingress-nginx https://github.com/kubernetes/ingress-nginx where attacker-provided data are included in a filename by the ingress-nginx Admission Controller feature, resulting in directory traversal within the container. This could result in denial of service, or when combined with other vulnerabilities, limited disclosure of Secret objects from the cluster.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | k8s.io/ingress-nginx | all versions | 1.11.5go get k8s.io/ingress-nginx@v1.11.5 |
| 🐹Go | k8s.io/ingress-nginx | ≥ 1.12.0-beta.0&&< 1.12.1 | 1.12.1go get k8s.io/ingress-nginx@v1.12.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/ingress-nginx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update k8s.io/ingress-nginx to 1.11.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-24513 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2025-24513 in your dependencies?
Find it across Go, including transitive dependencies.