NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-4864 — froxlor

MEDIUMFix: froxlor/froxlor@f2485ec

CVE-2022-4864 is a medium-severity (CVSS 5.3) CWE-88 vulnerability in froxlor/froxlor. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for froxlor/froxlor — see the affected versions and patch details below.

Argument Injection in froxlor/froxlor

Also known asGHSA-3v7m-2jrh-vc93
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4864.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘froxlor/froxlor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Argument Injection in GitHub repository froxlor/froxlor prior to 2.0.0-beta1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfroxlor/froxlor≥ 2.0.0-beta0&&< 2.0.0-beta12.0.0-beta1composer require froxlor/froxlor:^2.0.0-beta1

Affected Products

1 product · 1 configurations
Application
froxlorfroxlor
≤ 0.10.38.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froxlor/froxlor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froxlor/froxlor to 2.0.0-beta1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4864 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Argument Injection in GitHub repository froxlor/froxlor prior to 2.0.0-beta1.
O3 Security · Impact-Aware SCA

Is CVE-2022-4864 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-4864: froxlor — Fixed in 2.0.0-beta1