NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-48216 — @uniswap/universal-router

HIGHFix: Uniswap/universal-router@d82c668

CVE-2022-48216 is a high-severity (CVSS 7.5) CWE-667 vulnerability in @uniswap/universal-router. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @uniswap/universal-router — see the affected versions and patch details below.

Uniswap Universal Router Incorrect Authorization vulnerability

Also known asGHSA-7m37-cx35-qgmr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-48216.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.87%1.31%0.4%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

529other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@uniswap/universal-routernpm
106Kdownloads / week

Description

Uniswap Universal Router before 1.1.0 mishandles reentrancy. This would have allowed theft of funds.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@uniswap/universal-routerall versions1.1.0npm install @uniswap/universal-router@1.1.0

Affected Products

1 product · 1 configurations
OS
universal router firmwareuniswap
< 1.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @uniswap/universal-router, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @uniswap/universal-router to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-48216 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Uniswap Universal Router before 1.1.0 mishandles reentrancy. This would have allowed theft of funds.
O3 Security · Impact-Aware SCA

Is CVE-2022-48216 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-48216: @uniswap/universal — Fixed in 1.1.0