NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-45381 — pipeline-utility-steps

HIGHFix: jenkinsci/pipeline-utility-steps-plugin@01be8ac

CVE-2022-45381 is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.jenkins-ci.plugins:pipeline-utility-steps. A fix is available for org.jenkins-ci.plugins:pipeline-utility-steps — see the affected versions and patch details below.

Arbitrary file read vulnerability in Jenkins Pipeline Utility Steps Plugin

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-45381.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.65%1.30%1.94%0.3%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:pipeline-utility-steps

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Pipeline Utility Steps Plugin implements a readProperties Pipeline step that supports interpolation of variables using the Apache Commons Configuration library.

Pipeline Utility Steps Plugin 2.13.1 and earlier does not restrict the set of enabled prefix interpolators and bundles versions of this library that enable the file: prefix interpolator by default.

This allows attackers able to configure Pipelines to read arbitrary files from the Jenkins controller file system.

Pipeline Utility Steps Plugin 2.13.2 restricts the set of prefix interpolators enabled by default to base64Decoder:, base64Encoder:, date:, urlDecoder:, and urlEncoder:.

Administrators can set the Java system property org.jenkinsci.plugins.pipeline.utility.steps.conf.ReadPropertiesStepExecution.CUSTOM_PREFIX_INTERPOLATOR_LOOKUPS to customize which prefix interpolators are enabled.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:pipeline-utility-stepsall versions2.13.2org.jenkins-ci.plugins:pipeline-utility-steps:2.13.2

Affected Products

1 product · 1 configurations
Application
pipeline utility stepsjenkins
< 2.13.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:pipeline-utility-steps, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:pipeline-utility-steps to 2.13.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-45381 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

OpenShift 3.11 is already in the ELS support model phase. The Jenkins components are out of scope of the ELS support; hence the OpenShift 3.11 Jenkins component is marked in this CVE as out of support scope.

ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.10jenkins-2-plugins-0:4.10.1675144701-1.el8RHSA-2023:0560
Red Hat OpenShift Container Platform 4.9jenkins-2-plugins-0:4.9.1675668922-1.el8RHSA-2023:0777

Frequently Asked Questions

Pipeline Utility Steps Plugin implements a `readProperties` Pipeline step that supports interpolation of variables using the Apache Commons Configuration library. Pipeline Utility Steps Plugin 2.13.1 and earlier does not restrict the set of enabled prefix interpolators and bundles versions of this library that enable the `file:` prefix interpolator by default. This allows attackers able to configure Pipelines to read arbitrary files from the Jenkins controller file system. Pipeline Utility Steps Plugin 2.13.2 restricts the set of prefix interpolators enabled by default to `base64Decoder:`,
O3 Security · Impact-Aware SCA

Is CVE-2022-45381 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-45381: pipeline-utility-steps — Fixed in 2.13.2