CVE-2022-43484 — terasoluna-gfw-common
HIGHCVE-2022-43484 is a high-severity (CVSS 7.8) Improper Input Validation vulnerability in org.terasoluna.gfw:terasoluna-gfw-common. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.terasoluna.gfw:terasoluna-gfw-common — see the affected versions and patch details below.
TERASOLUNA Server Framework vulnerable to ClassLoader manipulation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-43484.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.terasoluna.gfw:terasoluna-gfw-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable to ClassLoader manipulation due to using the old version of Spring Framework which contains the vulnerability. The vulnerability is caused by an improper input validation issue in the binding mechanism of Spring MVC. By the application processing a specially crafted file, arbitrary code may be executed with the privileges of the application.
When using TERASOLUNA Global Framework 1.0.0 (Public review version), update to TERASOLUNA Server Framework for Java 5.7.1.SP1 (using Spring Framework 5.3.18). This vulnerability alone can be addressed by updating to TERASOLUNA Global Framework 1.0.1 (using Spring Framework 3.2.10) or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.terasoluna.gfw:terasoluna-gfw-common | all versions | 1.0.1.RELEASEorg.terasoluna.gfw:terasoluna-gfw-common:1.0.1.RELEASE |
Affected Products
terasoluna global frameworknttdataterasoluna server framework for java \(rich\)nttdataResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.terasoluna.gfw:terasoluna-gfw-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.terasoluna.gfw:terasoluna-gfw-common to 1.0.1.RELEASE or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-43484 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-43484 in your dependencies?
Find it across Maven, including transitive dependencies.