CVE-2022-42889 — commons-text
CRITICALCVE-2022-42889 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.apache.commons:commons-text. 46 public exploit references exist, so weaponization risk is real. A fix is available for org.apache.commons:commons-text — see the affected versions and patch details below.
Apache Commons Text prior to 1.10.0 allows RCE when applied to untrusted input due to insecure interpolation defaults
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42889.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2022-42889 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).
Where this sits among everything scored
Of 395,249 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
org.apache.commons:commons-text☕com.guicedee.services:commons-textReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Commons Text performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.text.lookup.StringLookup that performs the interpolation. Starting with version 1.5 and continuing through 1.9, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Text 1.10.0, which disables the problematic interpolators by default.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.commons:commons-text | ≥ 1.5&&< 1.10.0 | 1.10.0org.apache.commons:commons-text:1.10.0 |
| ☕Maven | com.guicedee.services:commons-text | all versions | No fix |
Affected Products
commons textapachesecurity threat response managerjuniperbluexpnetappResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Commons Text 1.10.0 - Remote Code Execution
by Arjun Chaudhary · Apr 18, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.commons:commons-text, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.commons:commons-text to 1.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42889 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In order to carry successful exploitation of this vulnerability, the following conditions must be in place on the affected target: - Usage of specific methods that interpolate the variables as described in the flaw - Usage of external input for those methods - Usage of that external input has to be unsanitized/no…
This flaw may be avoided by ensuring that any external inputs used with the Commons-Text lookup methods are sanitized properly. Untrusted input should always be thoroughly sanitized before using in any potentially risky situations.Source: Red Hat security advisory for CVE-2022-42889 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| OCP-Tools-4.12-RHEL-8 | jenkins-2-plugins-0:4.12.1683009955-1.el8 | RHSA-2023:3195 |
| OCP-Tools-4.12-RHEL-8 | jenkins-2-plugins-0:4.12.1698294000-1.el8 | RHSA-2023:6172 |
| OCP-Tools-4.12-RHEL-8 | jenkins-2-plugins-0:4.12.1706515741-1.el8 | RHSA-2024:0778 |
| OCP-Tools-4.13-RHEL-8 | jenkins-2-plugins-0:4.13.1684911916-1.el8 | RHSA-2023:3299 |
| OCP-Tools-4.13-RHEL-8 | jenkins-2-plugins-0:4.13.1698292274-1.el8 | RHSA-2023:6179 |
| OCP-Tools-4.13-RHEL-8 | jenkins-2-plugins-0:4.13.1706516346-1.el8 | RHSA-2024:0776 |
| OCP-Tools-4.14-RHEL-8 | jenkins-2-plugins-0:4.14.1699356715-1.el8 | RHSA-2023:7288 |
| OCP-Tools-4.14-RHEL-8 | jenkins-2-plugins-0:4.14.1706516441-1.el8 | RHSA-2024:0777 |
Frequently Asked Questions
Is CVE-2022-42889 in your dependencies?
Find it across Maven, including transitive dependencies.