NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-41911 — tensorflow

MEDIUMFix: tensorflow/tensorflow@1be7437

CVE-2022-41911 is a medium-severity (CVSS 4.8) CWE-704 vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

Invalid char to bool conversion when printing a tensor in Tensorflow

Also known asBIT-tensorflow-2022-41911GHSA-pf36-r9c6-h97jPYSEC-2026-1954PYSEC-2026-3222PYSEC-2026-939
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41911.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.31%0.63%0.94%0.1%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

When printing a tensor, we get it's data as a const char* array (since that's the underlying storage) and then we typecast it to the element type. However, conversions from char to bool are undefined if the char is not 0 or 1, so sanitizers/fuzzers will crash.

Patches

We have patched the issue in GitHub commit 1be743703279782a357adbf9b77dcb994fe8b508.

The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.10.1, TensorFlow 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability was discovered via internal fuzzing.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.8.4pip install --upgrade 'tensorflow==2.8.4'
🐍PyPItensorflow-cpu≥ 2.9.0&&< 2.9.32.9.3pip install --upgrade 'tensorflow-cpu==2.9.3'
🐍PyPItensorflow-gpu≥ 2.10.0&&< 2.10.12.10.1pip install --upgrade 'tensorflow-gpu==2.10.1'
🐍PyPItensorflow≥ 2.9.0&&< 2.9.32.9.3pip install --upgrade 'tensorflow==2.9.3'
🐍PyPItensorflow≥ 2.10.0&&< 2.10.12.10.1pip install --upgrade 'tensorflow==2.10.1'
🐍PyPItensorflow-cpuall versions2.8.4pip install --upgrade 'tensorflow-cpu==2.8.4'

Affected Products

1 product · 3 configurations
Application
tensorflowgoogle
≥ 2.9.0 && < 2.9.3
1 version
2.10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41911 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact When [printing a tensor](https://github.com/tensorflow/tensorflow/blob/807cae8a807960fd7ac2313cde73a11fc15e7942/tensorflow/core/framework/tensor.cc#L1200-L1227), we get it's data as a `const char*` array (since that's the underlying storage) and then we typecast it to the element type. However, conversions from `char` to `bool` are undefined if the `char` is not `0` or `1`, so sanitizers/fuzzers will crash. ### Patches We have patched the issue in GitHub commit [1be743703279782a357adbf9b77dcb994fe8b508](https://github.com/tensorflow/tensorflow/commit/1be743703279782a357adbf9b77dcb9
O3 Security · Impact-Aware SCA

Is CVE-2022-41911 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-41911: tensorflow — Fixed in 2.8.4