CVE-2022-41905 is a high-severity (CVSS 8.2) Cross-site Scripting (XSS) vulnerability in wsgidav. A fix is available for wsgidav — see the affected versions and patch details below.
wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41905.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wsgidavReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks.
Patches
Users can upgrade to v4.1.0
Workarounds
Set dir_browser.enable = False in the configuration. For instance, when using a Python dictionary to configure the library:
config = {
# your normal configuration
"dir_browser": {
"enable": False
},
}
app = WsgiDAVApp(config)
For more information
Note that an attacker cannot exploit this vulnerability, by simply uploading a file or folder with a manipulated file name. However if the WsgiDAV library is used in a scenario where untrusted data is displayed in the directory browser's user interface (e.g. 'realm' or user name, ...) XSS may happen.
If you have any questions or comments about this advisory:
- Open an issue in mar10/wsgidav
- See the security policy
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | wsgidav | ≥ 3.0.0a1&&< 4.1.0 | 4.1.0pip install --upgrade 'wsgidav==4.1.0' |
Affected Products
wsgidavwsgidav_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wsgidav, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wsgidav to 4.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41905 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-41905 in your dependencies?
Find it across PyPI, including transitive dependencies.