NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-41898 — tensorflow

MEDIUMFix: tensorflow/tensorflow@af4a6a3

CVE-2022-41898 is a medium-severity (CVSS 4.8) Improper Input Validation vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.

`CHECK` fail via inputs in `SparseFillEmptyRowsGrad` in Tensorflow

Also known asBIT-tensorflow-2022-41898GHSA-hq7g-wwwp-q46hPYSEC-2026-1008PYSEC-2026-3201PYSEC-2026-3340
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41898.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.2%0.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

If SparseFillEmptyRowsGrad is given empty inputs, TensorFlow will crash.

import tensorflow as tf
tf.raw_ops.SparseFillEmptyRowsGrad(
    reverse_index_map=[], grad_values=[], name=None
)

Patches

We have patched the issue in GitHub commit af4a6a3c8b95022c351edae94560acc61253a1b8.

The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Jiawei Liu, PhD student at University of Illinois, Urbana-Champaign.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.8.4pip install --upgrade 'tensorflow==2.8.4'
🐍PyPItensorflow≥ 2.9.0&&< 2.9.32.9.3pip install --upgrade 'tensorflow==2.9.3'
🐍PyPItensorflow≥ 2.10.0&&< 2.10.12.10.1pip install --upgrade 'tensorflow==2.10.1'
🐍PyPItensorflow-cpuall versions2.8.4pip install --upgrade 'tensorflow-cpu==2.8.4'
🐍PyPItensorflow-gpuall versions2.8.4pip install --upgrade 'tensorflow-gpu==2.8.4'
🐍PyPItensorflow-cpu≥ 2.9.0&&< 2.9.32.9.3pip install --upgrade 'tensorflow-cpu==2.9.3'

Affected Products

1 product · 3 configurations
Application
tensorflowgoogle
≥ 2.10.0 && < 2.10.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41898 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact If [`SparseFillEmptyRowsGrad`](https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/sparse_fill_empty_rows_op_gpu.cu.cc) is given empty inputs, TensorFlow will crash. ```python import tensorflow as tf tf.raw_ops.SparseFillEmptyRowsGrad( reverse_index_map=[], grad_values=[], name=None ) ``` ### Patches We have patched the issue in GitHub commit [af4a6a3c8b95022c351edae94560acc61253a1b8](https://github.com/tensorflow/tensorflow/commit/af4a6a3c8b95022c351edae94560acc61253a1b8). The fix will be included in TensorFlow 2.11. We will also cherrypick this comm
O3 Security · Impact-Aware SCA

Is CVE-2022-41898 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-41898: tensorflow — Fixed in 2.8.4