CVE-2022-41892 is a high-severity (CVSS 8.6) SQL Injection vulnerability in arches. A fix is available for arches — see the affected versions and patch details below.
Arches vulnerable to SQL Injection
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41892.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
arches🐍arches🐍archesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database.
Anyone running the impacted versions (<=6.1.1, 6.2.0, >=7.0.0, <=7.1.1) should upgrade as soon as possible.
Patches
The problem has been patched in the following versions: 6.1.2, 6.2.1, and 7.2.0 Users are strongly urged to upgrade to the most recent relevant patch.
Workarounds
There are no workarounds.
General References
https://www.w3schools.com/sql/sql_injection.asp https://en.wikipedia.org/wiki/SQL_injection
For more information
Post any questions to the Arches project forum.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | arches | all versions | 6.1.2pip install --upgrade 'arches==6.1.2' |
| 🐍PyPI | arches | ≥ 6.2.0&&< 6.2.1 | 6.2.1pip install --upgrade 'arches==6.2.1' |
| 🐍PyPI | arches | ≥ 7.0.0&&< 7.2.0 | 7.2.0pip install --upgrade 'arches==7.2.0' |
Affected Products
archesarchesprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for arches, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update arches to 6.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41892 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-41892 in your dependencies?
Find it across PyPI, including transitive dependencies.