CVE-2022-41891 is a medium-severity (CVSS 4.8) Improper Input Validation vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
Segfault in `tf.raw_ops.TensorListConcat` in Tensorflow
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41891.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If tf.raw_ops.TensorListConcat is given element_shape=[], it results segmentation fault which can be used to trigger a denial of service attack.
import tensorflow as tf
tf.raw_ops.TensorListConcat(
input_handle=tf.data.experimental.to_variant(tf.data.Dataset.from_tensor_slices([1, 2, 3])),
element_dtype=tf.dtypes.float32,
element_shape=[]
)
Patches
We have patched the issue in GitHub commit fc33f3dc4c14051a83eec6535b608abe1d355fde.
The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Tong Liu, ShanghaiTech University
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.8.4pip install --upgrade 'tensorflow==2.8.4' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow==2.9.3' |
| 🐍PyPI | tensorflow | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow==2.10.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.8.4pip install --upgrade 'tensorflow-cpu==2.8.4' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.8.4pip install --upgrade 'tensorflow-gpu==2.8.4' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow-cpu==2.9.3' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41891 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-41891 in your dependencies?
Find it across PyPI, including transitive dependencies.