CVE-2022-41887 is a medium-severity (CVSS 4.8) CWE-131 vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
Overflow in `tf.keras.losses.poisson` in Tensorflow
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41887.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu🐍tensorflow-gpuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
tf.keras.losses.poisson receives a y_pred and y_true that are passed through functor::mul in BinaryOp. If the resulting dimensions overflow an int32, TensorFlow will crash due to a size mismatch during broadcast assignment.
import numpy as np
import tensorflow as tf
true_value = tf.reshape(shape=[1, 2500000000], tensor = tf.zeros(dtype=tf.bool, shape=[50000, 50000]))
pred_value = np.array([[[-2]], [[8]]], dtype = np.float64)
tf.keras.losses.poisson(y_true=true_value,y_pred=pred_value)
Patches
We have patched the issue in GitHub commit c5b30379ba87cbe774b08ac50c1f6d36df4ebb7c.
The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1 and 2.9.3, as these are also affected and still in supported range. However, we will not cherrypick this commit into TensorFlow 2.8.x, as it depends on Eigen behavior that changed between 2.8 and 2.9.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Pattarakrit Rattankul.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.9.3pip install --upgrade 'tensorflow==2.9.3' |
| 🐍PyPI | tensorflow | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow==2.10.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.9.3pip install --upgrade 'tensorflow-cpu==2.9.3' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.9.3pip install --upgrade 'tensorflow-gpu==2.9.3' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow-cpu==2.10.1' |
| 🐍PyPI | tensorflow-gpu | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow-gpu==2.10.1' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41887 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2022-41887 in your dependencies?
Find it across PyPI, including transitive dependencies.