CVE-2022-41883 is a medium-severity (CVSS 6.8) Out-of-bounds Read vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
Out of bounds segmentation fault due to unequal op inputs in Tensorflow
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow-cpu🐍tensorflow-gpuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
tf.raw_ops.DynamicStitch specifies input sizes when it is registered.
REGISTER_OP("DynamicStitch")
.Input("indices: N * int32")
.Input("data: N * T")
.Output("merged: T")
.Attr("N : int >= 1")
.Attr("T : type")
.SetShapeFn(DynamicStitchShapeFunction);
When it receives a differing number of inputs, such as when it is called with an indices size 1 and a data size 2, it will crash.
import tensorflow as tf
# indices = 1*[tf.random.uniform([1,2], dtype=tf.dtypes.int32, maxval=100)]
indices = [tf.constant([[0, 1]]),]
# data = 2*[tf.random.uniform([1,2], dtype=tf.dtypes.float32, maxval=100)]
data = [tf.constant([[5, 6]]), tf.constant([[7, 8]])]
tf.raw_ops.DynamicStitch(
indices=indices,
data=data)
Patches
We have patched the issue in GitHub commit f5381e0e10b5a61344109c1b7c174c68110f7629.
The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1 as this is also affected.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Zizhuang Deng of IIE, UCAS
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow==2.10.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow-cpu==2.10.1' |
| 🐍PyPI | tensorflow-gpu | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow-gpu==2.10.1' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41883 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2022-41883 in your dependencies?
Find it across PyPI, including transitive dependencies.