CVE-2022-41828 is a high-severity (CVSS 8.8) CWE-704 vulnerability in com.amazon.redshift:redshift-jdbc42. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.amazon.redshift:redshift-jdbc42 — see the affected versions and patch details below.
com.amazon.redshift:redshift-jdbc42 vulnerable to remote command execution
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41828.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.amazon.redshift:redshift-jdbc42Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A potential remote command execution issue exists within redshift-jdbc42 versions 2.1.0.7 and below. When plugins are used with the driver, it instantiates plugin instances based on Java class names provided via the sslhostnameverifier, socketFactory, sslfactory, and sslpasswordcallback connection properties. In affected versions, the driver does not verify if a plugin class implements the expected interface before instantiatiaton. This can lead to loading of arbitrary Java classes, which a knowledgeable attacker with control over the JDBC URL can use to achieve remote code execution.
Patches
This issue is patched within redshift-jdbc-42 2.1.0.8 and above.
Workarounds
We advise customers using plugins to upgrade to redshift-jdbc42 version 2.1.0.8 or above. There are no known workarounds for this issue.
For more information
If you have any questions or comments about this advisory, please contact AWS Security at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.amazon.redshift:redshift-jdbc42 | all versions | 2.1.0.8com.amazon.redshift:redshift-jdbc42:2.1.0.8 |
Affected Products
amazon web services redshift java database connectivity driveramazonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.amazon.redshift:redshift-jdbc42, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.amazon.redshift:redshift-jdbc42 to 2.1.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41828 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-41828 in your dependencies?
Find it across Maven, including transitive dependencies.