NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-40734 — laravel-filemanager

MEDIUMFix: UniSharp/laravel-filemanager@8a357d0

CVE-2022-40734 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in unisharp/laravel-filemanager. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for unisharp/laravel-filemanager — see the affected versions and patch details below.

UniSharp Laravel Filemanager directory traversal vulnerability

Also known asGHSA-5m2h-7rf2-rpx6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%91.7%5.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘unisharp/laravel-filemanager

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

UniSharp laravel-filemanager (aka Laravel Filemanager) with league/flysystem version < 2.0.0 allows download?working_dir=%2F.. directory traversal to read arbitrary files, as exploited in the wild in June 2022.

Since v2.6.4, UniSharp laravel-filemanager (aka Laravel Filemanager) requires users to install league/flysystem version >= 2.0.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistunisharp/laravel-filemanagerall versions2.6.4composer require unisharp/laravel-filemanager:^2.6.4

Affected Products

1 product · 1 configurations
Application
laravel filemanagerunisharp
≤ 2.5.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for unisharp/laravel-filemanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update unisharp/laravel-filemanager to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40734 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2022-40734

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-40734 -u https://target
Template
Laravel Filemanager v2.5.1 - Local File Inclusion
Severity
medium
Impact
Successful exploitation of this vulnerability can lead to unauthorized access, sensitive data exposure, and remote code execution.
Remediation
Upgrade to a patched version of Laravel Filemanager v2.5.1 or apply the recommended security patches provided by the vendor.

Template by ProjectDiscovery nuclei-templates (arafatansari), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

UniSharp laravel-filemanager (aka Laravel Filemanager) with `league/flysystem` version `< 2.0.0` allows download?working_dir=%2F.. directory traversal to read arbitrary files, as exploited in the wild in June 2022. Since `v2.6.4`, UniSharp laravel-filemanager (aka Laravel Filemanager) requires users to install `league/flysystem` version `>= 2.0.0`.
O3 Security · Impact-Aware SCA

Is CVE-2022-40734 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-40734: laravel Path Traversal — Fixed in 2.6.4