CVE-2022-40716 is a medium-severity (CVSS 6.5) CWE-252 vulnerability in github.com/hashicorp/consul. A fix is available for github.com/hashicorp/consul — see the affected versions and patch details below.
HashiCorp Consul vulnerable to authorization bypass
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-40716.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/consul🐹github.com/hashicorp/consul🐹github.com/hashicorp/consulReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Consul and Consul Enterprise versions prior to 1.11.9, 1.12.5, and 1.13.2 do not check for multiple SAN URI values in a CSR on the internal RPC endpoint, enabling leverage of privileged access to bypass service mesh intentions. A specially crafted CSR sent directly to Consul’s internal server agent RPC endpoint can include multiple SAN URI values with additional service names. This issue has been fixed in versions 1.11.9, 1.12.5, and 1.13.2. There are no known workarounds.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/consul | all versions | 1.11.9go get github.com/hashicorp/consul@v1.11.9 |
| 🐹Go | github.com/hashicorp/consul | ≥ 1.12.0&&< 1.12.5 | 1.12.5go get github.com/hashicorp/consul@v1.12.5 |
| 🐹Go | github.com/hashicorp/consul | ≥ 1.13.0&&< 1.13.2 | 1.13.2go get github.com/hashicorp/consul@v1.13.2 |
Affected Products
consulhashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/consul, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/consul to 1.11.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40716 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-40716 in your dependencies?
Find it across Go, including transitive dependencies.