CVE-2020-28053 is a medium-severity (CVSS 6.5) CWE-863 vulnerability in github.com/hashicorp/consul. A fix is available for github.com/hashicorp/consul — see the affected versions and patch details below.
Privilege Escalation in HashiCorp Consul
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/consul🐹github.com/hashicorp/consul🐹github.com/hashicorp/consulReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Consul and Consul Enterprise 1.2.0 up to 1.8.5 allowed operators with operator:read ACL permissions to read the Connect CA private key configuration. Fixed in 1.6.10, 1.7.10, and 1.8.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/consul | ≥ 1.2.0&&< 1.6.10 | 1.6.10go get github.com/hashicorp/consul@v1.6.10 |
| 🐹Go | github.com/hashicorp/consul | ≥ 1.7.0&&< 1.7.10 | 1.7.10go get github.com/hashicorp/consul@v1.7.10 |
| 🐹Go | github.com/hashicorp/consul | ≥ 1.8.0&&< 1.8.6 | 1.8.6go get github.com/hashicorp/consul@v1.8.6 |
Affected Products
consulhashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/consul, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/consul to 1.6.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-28053 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2020-28053 in your dependencies?
Find it across Go, including transitive dependencies.