NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-39382 — @keystone-6/core

CRITICALFix: keystonejs/keystone#8063

CVE-2022-39382 is a critical-severity (CVSS 9.8) CWE-74 vulnerability in @keystone-6/core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @keystone-6/core — see the affected versions and patch details below.

NODE_ENV in Keystone defaults to development with esbuild

Also known asGHSA-25mx-2mxm-6343
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-39382.

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.99%1.53%2.08%2.63%2.1%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

19other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@keystone-6/corenpm
25Kdownloads / week

Description

Impact

@keystone-6/[email protected] || 3.0.1 users that use NODE_ENV in their own code (not dependencies) to trigger security-sensitive functionality in a production build are vulnerable to NODE_ENV being inlined to "development" for user code.

If your dependencies use NODE_ENV to trigger particular behaviours (optimisations, security or otherwise), they should still respect your environment's configured NODE_ENV variable and thereby be unaffected.

If you do not use NODE_ENV in your own code to trigger security-sensitive functionality, you are not impacted by this vulnerability. An example of code that would be affected, might be the following:

if (process.env.NODE_ENV !== 'production') {
  // this code would unintentionally run in your production builds
}

Technical Description

The problem comes from esbuild defaulting NODE_ENV to "development" when a platform configuration is undefined. You can read about why esbuild has that behaviour in their documentation, but the result for Keystone users is that user Typescript was compiled, and had inlined NODE_ENV to the constant "development".

Your application's dependencies, as found in node_modules (including @keystone-6/core), are typically not compiled as part of this process, and thus should be unaffected. Therefore any libraries that used NODE_ENV to trigger particular behaviours (optimisations, security or otherwise) should still respect your environment's NODE_ENV. We have tested this assumption by verifying that NODE_ENV=production yarn keystone start still uses secure cookies when using statelessSessions.

Thereby, the severity of this vulnerability is dependent on what functionality users conditionally triggered, in their own code, depending on the expectation that NODE_ENV would be correctly configured in their application. In accordance with Common Vulnerability Scoring System 2.3.3. Assume Vulnerable Configurations, this security advisory assumes vulnerable configurations and is thus marked as critical, but you should evaluate the true security impact for your application to determine a relevant score.

Patches

This vulnerability has been fixed in @keystone-6/[email protected], thanks to @mmachatschek in https://github.com/keystonejs/keystone/pull/8031/. We have added regression tests for this vulnerability in https://github.com/keystonejs/keystone/pull/8063.

Workarounds

If you cannot upgrade your @keystone-6/core version for any reason, your best alternative is to remove any code that uses NODE_ENV in a way that may reasonably impact your application security.

References

For more information

Thanks to Austin Burdine for reporting this problem as a potential security vulnerability.

If you have any questions around this security advisory, please don't hesitate to contact us at [email protected], or open an issue on GitHub.

If you have a security flaw to report for any software in this repository, please see our SECURITY policy.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@keystone-6/core≥ 3.0.0&&< 3.0.23.0.2npm install @keystone-6/core@3.0.2

Affected Products

1 product · 2 configurations
Application
keystonekeystonejs
2 versions
3.0.03.0.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @keystone-6/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @keystone-6/core to 3.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39382 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact `@keystone-6/[email protected] || 3.0.1` users that use `NODE_ENV` in their own code (**not dependencies**) to trigger security-sensitive functionality in a production build are vulnerable to `NODE_ENV` being inlined to `"development"` for user code. If your dependencies use `NODE_ENV` to trigger particular behaviours (optimisations, security or otherwise), they should still respect your environment's configured `NODE_ENV` variable and thereby be unaffected. If you do not use `NODE_ENV` in your own code to trigger security-sensitive functionality, **you are not impacted** by this vulnera
O3 Security · Impact-Aware SCA

Is CVE-2022-39382 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-39382: @keystone-6/core — Fixed in 3.0.2