NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-3869 — froxlor

MEDIUMFix: froxlor/froxlor@3f10a4a

CVE-2022-3869 is a medium-severity (CVSS 6.5) Code Injection vulnerability in froxlor/froxlor. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for froxlor/froxlor — see the affected versions and patch details below.

Code Injection in froxlor/froxlor

Also known asGHSA-6rjv-xxgr-v57x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3869.

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk+0.43%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%6.31%12.6%18.9%14.9%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘froxlor/froxlor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Code Injection in GitHub repository froxlor/froxlor prior to version 0.10.38.2. There are currently no known workarounds, please upgrade to version 0.10.38.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfroxlor/froxlorall versions0.10.38.2composer require froxlor/froxlor:^0.10.38.2

Affected Products

1 product · 1 configurations
Application
froxlorfroxlor
< 0.10.38.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froxlor/froxlor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froxlor/froxlor to 0.10.38.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3869 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2022-3869

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-3869 -u https://target
Template
Froxlor < 0.10.38.2. - HTML Injection
Severity
medium
Impact
Attackers can inject arbitrary HTML content through the customermail parameter, potentially displaying fake content to users and facilitating phishing attacks against Froxlor administrators.
Remediation
Update Froxlor to version 0.10.38.2 or later that properly sanitizes the customermail parameter and encodes HTML output.

Template by ProjectDiscovery nuclei-templates (ctflearner), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Code Injection in GitHub repository froxlor/froxlor prior to version 0.10.38.2. There are currently no known workarounds, please upgrade to version 0.10.38.2.
O3 Security · Impact-Aware SCA

Is CVE-2022-3869 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-3869: froxlor RCE — Fixed in 0.10.38.2