CVE-2022-38060 is a high-severity (CVSS 7.8) Improper Privilege Management vulnerability in kolla. A fix is available for kolla — see the affected versions and patch details below.
OpenStack Kolla sudo privilege escalation vulnerability
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-38060.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
kollaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A privilege escalation vulnerability exists in the sudo functionality of OpenStack Kolla git master 05194e7618. A misconfiguration in /etc/sudoers within a container can lead to increased privileges.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | kolla | all versions | 15.0.0.0rc1pip install --upgrade 'kolla==15.0.0.0rc1' |
Affected Products
kollaopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kolla, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update kolla to 15.0.0.0rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-38060 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To exploit this vulnerability, an attacker would need to have specialized access that allows them to modify how the container is run. The attacker would need to either modify the container's definition (such as by configuring environment variables or selecting the container image) or modify files in the container's…
/etc/sudoers within the container should use the `secure_path` option to prevent the PATH environment variable from being modified. However, this will not prevent other possibly dangerous environment variables from being changed. Ideally, the `setenv` option would be removed from /etc/sudoers altogether, and `env_keep` could be used for any safe environment variables that do not introduce security holes. To avoid container compromises resulting in host compromise, avoid using privileged containers; prefer adding individual capabilities as needed.Source: Red Hat security advisory for CVE-2022-38060 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 17.1 for RHEL 8 | openstack-tripleo-common-0:15.4.1-17.1.20230927003755.el8ost | RHSA-2024:0191 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | openstack-tripleo-common-0:15.4.1-17.1.20230927010819.el9ost | RHSA-2024:0216 |
Frequently Asked Questions
Is CVE-2022-38060 in your dependencies?
Find it across PyPI, including transitive dependencies.