NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-37435 — shenyu-common

HIGHFix: apache/shenyu#3658

CVE-2022-37435 is a high-severity (CVSS 8.8) CWE-732 vulnerability in org.apache.shenyu:shenyu-common. A fix is available for org.apache.shenyu:shenyu-common — see the affected versions and patch details below.

Apache ShenYu Admin Improper Privilege Management

Also known asGHSA-fjjw-82xw-vfc2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.02%0.63%1.23%1.84%0.5%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.shenyu:shenyu-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache ShenYu Admin has insecure permissions, which may allow low-privilege administrators to modify high-privilege administrator's passwords. This issue affects Apache ShenYu 2.4.2 and 2.4.3. Version 2.5.0 contains a patch for this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.shenyu:shenyu-common≥ 2.4.2&&< 2.5.02.5.0org.apache.shenyu:shenyu-common:2.5.0

Affected Products

1 product · 2 configurations
Application
shenyuapache
2 versions
2.4.22.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shenyu:shenyu-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.shenyu:shenyu-common to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-37435 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache ShenYu Admin has insecure permissions, which may allow low-privilege administrators to modify high-privilege administrator's passwords. This issue affects Apache ShenYu 2.4.2 and 2.4.3. Version 2.5.0 contains a patch for this issue.
O3 Security · Impact-Aware SCA

Is CVE-2022-37435 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-37435: shenyu-common — Fixed in 2.5.0