NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-23944 — shenyu-common

CRITICALFix: apache/incubator-shenyu#2462

CVE-2022-23944 is a critical-severity (CVSS 9.1) CWE-862 vulnerability in org.apache.shenyu:shenyu-common. EPSS puts its 30-day exploitation probability at 79.0% (100th percentile). A fix is available for org.apache.shenyu:shenyu-common — see the affected versions and patch details below.

Apache ShenYu 2.4.1 Improper access control

Also known asGHSA-6v39-p2xq-g5c3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
79.0%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
75.7%81.6%87.4%93.2%89.9%79.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.shenyu:shenyu-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.shenyu:shenyu-common≥ 2.4.0&&< 2.4.22.4.2org.apache.shenyu:shenyu-common:2.4.2

Affected Products

1 product · 2 configurations
Application
shenyuapache
2 versions
2.4.02.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shenyu:shenyu-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.shenyu:shenyu-common to 2.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23944 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

How to detect CVE-2022-23944

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-23944 -u https://target
Template
Apache ShenYu Admin Unauth Access
Severity
critical
Impact
Successful exploitation of this vulnerability can lead to unauthorized access to sensitive information and potential compromise of the Apache ShenYu admin panel.
Remediation
Upgrade to Apache ShenYu (incubating) 2.4.2 or apply the appropriate patch.

Template by ProjectDiscovery nuclei-templates (cckuakilong), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.
O3 Security · Impact-Aware SCA

Is CVE-2022-23944 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-23944: shenyu-common — Fixed in 2.4.2