NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-36663 — oxauth-common

CRITICALFix: GluuFederation/oxAuth@58c4ac9

CVE-2022-36663 is a critical-severity (CVSS 9.8) Server-Side Request Forgery (SSRF) vulnerability in org.gluu:oxauth-common. A fix is available for org.gluu:oxauth-common — see the affected versions and patch details below.

Gluu Oxauth before v4.4.1 vulnerable to Server-Side Request Forgery attacks via a crafted request_uri parameter

Also known asGHSA-hc94-9v26-gxwv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%6.91%13.8%20.7%16.4%2.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.gluu:oxauth-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Gluu Oxauth before v4.4.1 allows attackers to execute blind SSRF (Server-Side Request Forgery) attacks via a crafted request_uri parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.gluu:oxauth-commonall versions4.4.1org.gluu:oxauth-common:4.4.1

Affected Products

1 product · 1 configurations
Application
oxauthgluu
< 4.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.gluu:oxauth-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.gluu:oxauth-common to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36663 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

Gluu Oxauth before v4.4.1 allows attackers to execute blind SSRF (Server-Side Request Forgery) attacks via a crafted request_uri parameter.
O3 Security · Impact-Aware SCA

Is CVE-2022-36663 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-36663: oxauth-common SSRF — Fixed in 4.4.1