CVE-2022-36093 is a high-severity (CVSS 8.5) Improper Authentication vulnerability in org.xwiki.platform:xwiki-platform-web-templates. A fix is available for org.xwiki.platform:xwiki-platform-web-templates — see the affected versions and patch details below.
XWiki Platform Web Templates vulnerable to Unauthorized User Registration Through the Distribution Wizard
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36093.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-web☕org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-webReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
By passing a template of the distribution wizard to the xpart template, user accounts can be created even when user registration is disabled. This also circumvents any email verification. Before versions 14.2 and 13.10.4, this can also be exploited on a private wiki, thus potentially giving the attacker access to the wiki. Depending on the configured default rights of users, this could also give attackers write access to an otherwise read-only public wiki. Users can also be created when an external authentication system like LDAP is configured, but authentication fails unless the authentication system supports a bypass/local accounts are enabled in addition to the external authentication system.
Patches
This issue has been patched in XWiki 13.10.5 and 14.3RC1.
Workarounds
It is possible to replace xpart.vm, the entry point for this attack, by a patched version from the patch without updating XWiki.
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | all versions | 13.10.5org.xwiki.platform:xwiki-platform-web-templates:13.10.5 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web | ≥ 8.0-rc-1&&< 13.10.5 | 13.10.5org.xwiki.platform:xwiki-platform-web:13.10.5 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 14.0&&< 14.3-rc-1 | 14.3-rc-1org.xwiki.platform:xwiki-platform-web-templates:14.3-rc-1 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web | ≥ 14.0&&< 14.3-rc-1 | 14.3-rc-1org.xwiki.platform:xwiki-platform-web:14.3-rc-1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-web-templates, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-web-templates to 13.10.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36093 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-36093 in your dependencies?
Find it across Maven, including transitive dependencies.