CVE-2026-40105 — xwiki-platform-web-templa…
Fix: xwiki/xwiki-platform@3c8a2ecCVE-2026-40105 is a CWE-80 vulnerability in org.xwiki.platform:xwiki-platform-web-templates. A fix is available for org.xwiki.platform:xwiki-platform-web-templates — see the affected versions and patch details below.
XWiki has Reflected Cross-Site Scripting (XSS) in its page history compare functionality
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40105.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-web-templates☕org.xwiki.platform:xwiki-platform-web-templatesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 10.4-rc-1, through 16.10.15, 17.0.0-rc-1, through 17.4.7 and 17.5.0-rc-1 through 17.10.0 contain a reflected cross-site scripting vulnerability (XSS) in the comparison view between revisions of a page allows executing JavaScript code in the user's browser. If the current user is an admin, this can not only affect the current user but also the confidentiality, integrity and availability of the whole XWiki instance. If developers are unable to update immediately, they can apply the patch manually to templates/changesdoc.vm in the deployed WAR.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 10.4-rc-1&&< 16.10.16 | 16.10.16org.xwiki.platform:xwiki-platform-web-templates:16.10.16 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 17.0.0-rc-1&&< 17.4.8 | 17.4.8org.xwiki.platform:xwiki-platform-web-templates:17.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-templates | ≥ 17.5.0-rc-1&&< 17.10.1 | 17.10.1org.xwiki.platform:xwiki-platform-web-templates:17.10.1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-web-templates, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-web-templates to 16.10.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40105 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2026-40105
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2026-40105 -u https://target- Template
- XWiki - Cross-Site Scripting
- Severity
- medium
- Impact
- Attackers can execute JavaScript in users' browsers, potentially compromising admin accounts and the entire XWiki instance.
- Remediation
- Update to a version later than 17.10.0 or apply the patch to templates/changesdoc.vm manually.
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2026-40105 in your dependencies?
Find it across Maven, including transitive dependencies.