CVE-2022-36027 is a medium-severity (CVSS 5.9) Improper Input Validation vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
Segfault TFLite converter on per-channel quantized transposed convolutions in TensorFlow
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36027.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When converting transposed convolutions using per-channel weight quantization the converter segfaults and crashes the Python process.
import tensorflow as tf
class QuantConv2DTransposed(tf.keras.layers.Layer):
def build(self, input_shape):
self.kernel = self.add_weight("kernel", [3, 3, input_shape[-1], 24])
def call(self, inputs):
filters = tf.quantization.fake_quant_with_min_max_vars_per_channel(
self.kernel, -3.0 * tf.ones([24]), 3.0 * tf.ones([24]), narrow_range=True
)
filters = tf.transpose(filters, (0, 1, 3, 2))
return tf.nn.conv2d_transpose(inputs, filters, [*inputs.shape[:-1], 24], 1)
inp = tf.keras.Input(shape=(6, 8, 48), batch_size=1)
x = tf.quantization.fake_quant_with_min_max_vars(inp, -3.0, 3.0, narrow_range=True)
x = QuantConv2DTransposed()(x)
x = tf.quantization.fake_quant_with_min_max_vars(x, -3.0, 3.0, narrow_range=True)
model = tf.keras.Model(inp, x)
model.save("/tmp/testing")
converter = tf.lite.TFLiteConverter.from_saved_model("/tmp/testing")
converter.optimizations = [tf.lite.Optimize.DEFAULT]
# terminated by signal SIGSEGV (Address boundary error)
tflite_model = converter.convert()
Patches
We have patched the issue in GitHub commit aa0b852a4588cea4d36b74feb05d93055540b450.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Lukas Geiger via Github issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow==2.9.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow-cpu==2.9.1' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36027 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-36027 in your dependencies?
Find it across PyPI, including transitive dependencies.