CVE-2022-36020 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in typo3/html-sanitizer. A fix is available for typo3/html-sanitizer — see the affected versions and patch details below.
Bypass of Cross-Site Scripting Protection in typo3/html-sanitizer
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36020.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/html-sanitizer🐘typo3/html-sanitizer🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The typo3/html-sanitizer package is an HTML sanitizer, written in PHP, aiming to provide XSS-safe markup based on explicitly allowed tags, attributes and values. Due to a parsing issue in the upstream package masterminds/html5, malicious markup used in a sequence with special HTML comments cannot be filtered and sanitized. This allows for a bypass of the cross-site scripting mechanism of typo3/html-sanitizer. This issue has been addressed in versions 1.0.7 and 2.0.16 of the typo3/html-sanitizer package. Users are advised to upgrade. There are no known workarounds for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/html-sanitizer | ≥ 1.0.0&&< 1.0.7 | 1.0.7composer require typo3/html-sanitizer:^1.0.7 |
| 🐘Packagist | typo3/html-sanitizer | ≥ 2.0.0&&< 2.0.16 | 2.0.16composer require typo3/html-sanitizer:^2.0.16 |
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.32 | 10.4.32composer require typo3/cms-core:^10.4.32 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.16 | 11.5.16composer require typo3/cms-core:^11.5.16 |
| 🐘Packagist | typo3/cms | ≥ 10.0.0&&< 10.4.32 | 10.4.32composer require typo3/cms:^10.4.32 |
| 🐘Packagist | typo3/cms | ≥ 11.0.0&&< 11.5.16 | 11.5.16composer require typo3/cms:^11.5.16 |
Affected Products
html sanitizertypo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/html-sanitizer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/html-sanitizer to 1.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36020 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-36020 in your dependencies?
Find it across Packagist, including transitive dependencies.