CVE-2022-36015 is a medium-severity (CVSS 5.9) CWE-190 vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
Integer overflow in math ops in TensorFlow
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36015.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When RangeSize receives values that do not fit into an int64_t, it crashes.
auto size = (std::is_integral<T>::value
? ((Eigen::numext::abs(limit - start) +
Eigen::numext::abs(delta) - T(1)) /
Eigen::numext::abs(delta))
: (Eigen::numext::ceil(
Eigen::numext::abs((limit - start) / delta))));
// This check does not cover all cases.
if (size > std::numeric_limits<int64_t>::max()) {
return errors::InvalidArgument("Requires ((limit - start) / delta) <= ",
std::numeric_limits<int64_t>::max());
}
c->set_output(0, c->Vector(static_cast<int64_t>(size)));
return Status::OK();
}
Patches
We have patched the issue in GitHub commit 37e64539cd29fcfb814c4451152a60f5d107b0f0. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow==2.9.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow-cpu==2.9.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36015 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-36015 in your dependencies?
Find it across PyPI, including transitive dependencies.